CSLA 4.2 Mono Support

CSLA 4.2 Mono Support

Old forum URL: forums.lhotka.net/forums/t/10731.aspx

reyhc posted on Saturday, October 01, 2011

This is my first post in this forum, so let me start by saying that I consider CSLA a great product, and one of the most important contributions to the .NET developers community. I have always seen in CSLA the framework that Microsoft have never provided in order to build Business applications.

I was very happy when I heard about efforts to support Mono. A week ago I started to try CSLA on Mono, but all my efforts has been unsuccessful.  There are some posts about the topic, but I have not been able to find any real steps about how to do it. I have tried many things myself, like compiling the source code with mono, compiling with mono profiles in VS 2010, and others.

Basically, what I want is to create a 3-tier CSLA application using Silverlight 4 as the presentation and hosting the data portal and DAL on linux-apache with mod_mono. I have some asp.net applications already running on my linux server using mono 2.10. So my issue is not related with mono configurations.

I'm using the ProjectTracker sample application with the mockDB DAL in order to get my first CSLA application running on mono-linux. It does not matter how I compile and deploy this application I always get the same error: 

Unhandled Exception: System.TypeLoadException: Could not load type 'System.Runtime.Versioning.TargetFrameworkAttribute' from assembly 'WcfAppServer'.  at Mono.CSharp.Driver.Compile () [0x00000] in :0   at Mono.CSharp.Driver.Main (System.String[] args) [0x00000] in :0 

I have got this error many times before, while deploying applications to Mono, and it usually has been related with compatibility issues, but this time I have not been able to solve it.

If someone have been able to get this working and can provide the steps to follow, versions to use and/or what needs to re-compiled using specific .net frameworks, it will be appreciated.


RockfordLhotka replied on Saturday, October 01, 2011

Jonny can provide more detailed instructions.

First though, make sure you are using the latest Xamarin mono release, and that you are using the latest 4.2 code from the svn repository. The latest public pre-release of 4.2 pre-dates the whole Attachmate/Novell/Xamarin thing.

We have been working on this from the VS10 side of things. I don't know if we have instructions for building it on Linux for example, but the sln opens and builds in VS10 if you have the latest mono and latest CSLA code.

reyhc replied on Tuesday, October 04, 2011

Thanks for your  quick reply.

I'm using already the latest versions of both products. I'm compiling with VS2010 too, but my issues are not while compiling. I can compile perfectly, even in MonoDevelop. The issues are once I deploy the asp.net application to the linux server and I try to run it. So, I may be missing something. That's why I was asking for more detailed steps to follow.



RockfordLhotka replied on Tuesday, October 04, 2011

This is an area where we are admittedly weak - in terms of experience, testing, etc. To my knowledge, none of the dev team are big Linux users.

In short, any help you (or anyone else) can provide around figuring out the quirks with using mono and/or CSLA in Linux is very much appreciated!

Copyright (c) Marimer LLC