Csla Sample Bugs

Csla Sample Bugs

Old forum URL: forums.lhotka.net/forums/t/10795.aspx

cnowicki posted on Friday, October 21, 2011

Hi, I've just downloaded the Csla 4.1 and the corresponding samples. 

The first sample I tried was the ClsaMVC sample because I'm a fan of MVC and I'm curious to see how Clsa works - I learn best by messing around with samples. In any case, the sample simply won't run - it gives the error shown below.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Could not load file or assembly 'Csla.Web.Mvc, Version=, Culture=neutral, PublicKeyToken=93be5fdc093e4c30' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Source Error: 

Line 24:         <add assembly="System.Web.Routing, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
Line 25:         <add assembly="System.Data.Linq, Version=, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
Line 26:         <add assembly="Csla.Web.Mvc, Version=, Culture=neutral, PublicKeyToken=93be5fdc093e4c30"/>
Line 27:       </assemblies>
Line 28:     </compilation>

Source File: C:\Users\christian.nowicki\Documents\Visual Studio 2010\Projects\CSLA Samples\NET\cs\CslaMVC\CslaMVC.Web\web.config    Line: 26 

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Csla.Web.Mvc, Version=, Culture=neutral, PublicKeyToken=93be5fdc093e4c30' could not be loaded


Originally I had downloaded the beta (version 4.2) and tried to compile and run the BusinessRuleDemo - this did not work - the sample contained a number of compiler errors. Then I tried the MVC sample - didn't compile either. So I thought to myself - ok this is a Beta and downloaded the latest "stable" version - which contains more bugs.

I posted this as a discussion rather than a question because I can get the demos working. The reason for the post is that I would like to see CSLA do well. I know it is being shown at various Microsoft shows, however I can't think of a better way to turn off potential interest than buggy samples.



ajj3085 replied on Friday, October 21, 2011

Check the version number in the add assembly for Csla.Web.Mvc.  It probably should be, or whatever version of Csla you're using (the on you posted looks like Csla 4.0 (4.0.2 to be exact).

Copyright (c) Marimer LLC