CSLA 4.5 beta version 4.5.11 BCL References

CSLA 4.5 beta version 4.5.11 BCL References

Old forum URL: forums.lhotka.net/forums/t/11823.aspx

NET-H24 posted on Thursday, February 07, 2013

I tried to upgrade one of our project from CSLA 4.5.10 to 4.5.11 BETA today

Downloaded the binaries from Nuget

PM> Install-Package CSLA-Core -Pre


The link mentioned a dependencies on Microsoft.Bcl.Async

So Downloaded the same and referred to my project 

But it gave an error

Could not load file or assembly 'System.Threading.Tasks, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.

The Version i have downloaded file Microsoft.Threading.Tasks.dll is

Please let me know if I am missing something here.

Note : I also tried to check the samples available after installing CSLA from the wix Installer. The SImpleApp also had the same error.


I tried to resolve the issue and came across this


But the workaround didn't worked from me either.

NET-H24 replied on Thursday, February 07, 2013

My mistake, As there were several project the references were not properly provided.

Used Manage Nuget Pagkages to resolve this issue.

RockfordLhotka replied on Thursday, February 07, 2013

I ran into this as well over the past few days. It seems like the process of upgrading from the old Microsoft async library to the new one doesn't always work smoothly.

It sounds like you got lucky and could resolve it with package manager.

In a couple cases I had to do some manual editing of app.config files and some other stuff. It was a PITA...

ngm replied on Saturday, February 09, 2013

There are also several nasty bugs still not fixed in v1.0.14.

ConfigureAwait(false) doesn't work, exception stack trace is not preserved as it is in .NET v4.5. There was more, but didn't have time to test with this version, hopefully they fixed it.

- ngm


Copyright (c) Marimer LLC