4.5.30 Project Tracker sample, cannot login

4.5.30 Project Tracker sample, cannot login

Old forum URL: forums.lhotka.net/forums/t/12199.aspx

Tom_W posted on Tuesday, October 29, 2013

Hi all

After several happy years of 3.6.3 and Winforms we are now beginning the transition to asp.net and trying to get up to speed with the newer features of CSLA too.

I'm trying to get the 4.5.30 Project Tracker sample working in Visual Studio 2013 which has taken a while, but I now have everything compiling and the mvc, winforms and wpf projects running and returning read only data.

What I'm stuck with is logging in, it doesn't work for me in any of the projects.  I can attach to (localdb)\11 and see the aspnetdb database fine in the Server Explorer in Visual Studio and obviously I'm returning data ok from the actual project tracker database.  Is there something obvious I'm missing?


The actual issue is that the call to Membership.ValidateUser() is returning false in ProjectTracker.DalEf.UserDal  - what would cause that?

Quick steps to reproduce:  Open the ProjectTracker sample in VS2013, unload the Mvc3UI project, set the WfUI project as the startup project, run it and try and login.

Tom_W replied on Wednesday, October 30, 2013

This is driving me bonkers, all I want to do is get the sample app up and running!

I created a WebApplication in VS2010 and once I ran that up and registered a user it created the aspnetdb fine and connected to it.  

VS2012/2013 no longer seem to use aspnetdb, but I created WebApplication projects in both of those too and they both worked fine too.

So... seems to be something to do with the configuration of ProjectTracker.

Has anyone run ProjectTracker for 4.5.30 and had it work straight out of the box?

skagen00 replied on Wednesday, October 30, 2013

This isn't going to be helpful because I don't remember what the problem was, but no - getting 4.5.30 going (to run the MVC example) was a bit of a bear.  I did get it running eventually when I did try it.  (I don't have my configuration any longer, sorry).

Tom_W replied on Wednesday, October 30, 2013

Thanks for replying, nice to know I wasn't the only one at least!

I have just this minute solved it, and it is a corker.  I thought I had tried everything, but then I checked the databases on (localdb)\v11.0 in SQL Management Studio, and discovered they were readonly... and then the penny dropped.... the samples are installed in Program Files by the 4.5.30 installer.  As soon as I granted the Users group on my PC write full priveleges to the samples directory it all worked fine.

Absolutely no indication of anything like that in the error messages returned by any part of .net of course...  That's six hours of my life I'll never get back!

I don't understand why that was necessary though, I thought IIS Express ran in the local user account and my user account has full privileges on Program Files.  Odd.

Edit:  Thinking about this logically, the issue must be that the user account SQL Express is running in doesn't have permissions to write to Program Files.

Tom_W replied on Wednesday, October 30, 2013

I have now documented everything I did to get ProjectTracker running in VS2013 in a separate post: http://forums.lhotka.net/forums/p/12200/56461.aspx#56461

Copyright (c) Marimer LLC