Silverlight business assemblies

Silverlight business assemblies

Old forum URL:

wjcomeaux posted on Wednesday, September 16, 2009

Hello all:

I am trying to put together a small Silverlight application and Silverlight is throwing a System.IO.FileNotFoundException. Could not load assembly 'Hps.Security.SingleSignOn.Business, Version

Both the server and client libraries have the same AssembleInfo.cs file and they are both version so the Version in the error makes even less sense.

AFAIK I've got everything referenced correctly. Server library and web app both reference the normal CSLA. Client library and silverlight app both reference the csla for Silverlight. Silverlight app references client library and web app references server library.

The only thing I see so far that might cause a problem is I've had to add my clsa objects to an existing Hps.Security library which contains other POCO and non CLSA business objects. I've made the Client version of this library contain links to only the CSLA objects I need for this project.
Could this be the reason for this error?

**Edit. I just created two new test projects SilverlightTest.Server and Client,I referenced them all the same way and I'm still getting the same error (though now about SilverlightTest.Business).


P.S. Great Silverlight videos Rocky!

wjcomeaux replied on Wednesday, September 16, 2009

Solved it. I had set up my CslaDataProvider like this
ObjectType="Hps.Security.SingleSignOn.Business.User, Hps.Security.SingleSignOn.Business"
but it needed to be
ObjectType="Hps.Security.SingleSignOn.Business.User, Hps.Security"


Copyright (c) Marimer LLC