Reference Problem

Reference Problem

Old forum URL:

ErikJL posted on Wednesday, June 30, 2010

I started using a different computer today, downloaded some code from TFS (a project with Csla derived objects), opened the solution and found half the references in the Csla project were broken. I could not find the references via "Add Reference --> .NET" tab, so I had to manually browse for them in the GAC (GAC_32, and GAC_MSIL). The references seemingly fixed, I attempted to build the Csla project and an error came back saying

" Project file must include the .NET Framework assembly 'PresentationCore, PresentationFramework' in the reference list.    Csla"

I clearly have the 2 references in the Csla references folder. Cleaning/Rebuilding the project, unloading/reloading the solution, even rebooting did not solve the issue. I'm flabbergasted. Any ideas?

I'm using Csla 3.8.2 and .NET 3.5 (.NET 4.0 is installed on the machine however).

RockfordLhotka replied on Wednesday, June 30, 2010

You are trying to build the Csla project and it can't find references? It sounds like your .NET install is somehow broken. Is .NET 3.5 SP1 installed on the machine, or just .NET 4?

ErikJL replied on Wednesday, June 30, 2010

Looking in C:\WINDOWS\Microsoft.NET\Framework, I have the following:







So no .NET 3.5 SP1 that I can see. I did run the .NET 4 installer and ran the "Repair" option, should have mentioned that in the original post. I will look for a 3.5 SP1 installer.

ErikJL replied on Wednesday, June 30, 2010

I'm running the .NET 3.5SP1 installer, and it appears that it's already installed: I only get the Repair and Remove options. I will move ahead with the Repair option.

ErikJL replied on Wednesday, June 30, 2010

Ok I ran the .NET 3.5SP1 Repair option, and that worked.

Copyright (c) Marimer LLC