CSLA in WorkflowService

CSLA in WorkflowService

Old forum URL: forums.lhotka.net/forums/t/9787.aspx

wjcomeaux posted on Sunday, November 21, 2010

Hey guys, I'm toying around with WCF Workflow Services and I've run into a snag with using CSLA objects.

I've got a business layer generated with CodeSmith that contains an Account editable root object.
The service has a Recieve task that accepts accountID. I want to use the accountID to see if a record exists for it. Any idea how this is done in WF?

My first guess was to define a variable of type Account and use an InvokeMethod operation to call the factory method passing the accountID. However, as soon as I try to create a variable of type Account I get a message box telling me "The selected type could not be created".

I even when into the generated code and made the constructor public just for grins and I get the same error.

Have any of you experienced this? What was the fix?

wjcomeaux replied on Monday, November 22, 2010

This can be ignored. I'm not sure what the issue is but I got to work and tried a similar scenario using a different generated business layer and I can indeed use CSLA objects in the Workflow Service. Has to be some configuration with my other project.


bniemyjski replied on Tuesday, November 23, 2010


I think Rocky is on vacation... I'm not that familiar with Workflow Service but I'll take a look. Can you please attach or email me your sample repro solution and database script for this table and I'll take a look and see if I can figure it out.


-Blake Niemyjski

Copyright (c) Marimer LLC