Deployment Errors in Visual Studio 2010

Deployment Errors in Visual Studio 2010

Old forum URL:

rdcrosthwait posted on Thursday, December 09, 2010

I have been receiving the following errors related to PropertyInfo<String>

C#: Several methods are applicable to '(string,string)'; 'Csla.PropertyInfo<T>.PropertyInfo(string,T)' and 'Csla.PropertyInfo<T>.PropertyInfo(string, string)'

The code that it is complanining about is below







static PropertyInfo<string> DescriptionProperty = RegisterProperty(new PropertyInfo<string>("Description", "Project Description"));




Public string Description





get { return GetProperty(DescriptionProperty); }


JonnyBee replied on Thursday, December 09, 2010

Have you tried to update your code to use the lambda parameter?

private static PropertyInfo<string> DescriptionProperty = RegisterProperty(p => p.Description, "Project Description"));

rdcrosthwait replied on Thursday, December 09, 2010

I will give that a try and let you know my results


rdcrosthwait replied on Friday, December 10, 2010

Thanks that appears to work and cleared the error.  Not sure why the error occurred in the first place.  Or at least why it compiles and works just fine except it is flagged as a Deployment error.  I will research that though.

JonnyBee replied on Monday, December 13, 2010

Which version of CSLA are you using and which runtime (NET/SL/WP) throws the exception.

I tried your property info declaration in both .NET4 + WindowsForms and SL4 and it rund just fine.

Copyright (c) Marimer LLC